HSRP IN DEPTH

As you see in the thumbnail, that network diagram we are going to implement and follow various scenarios of HSRP working in detail with packet flow. This is practical design on customer site connected to MPLS , devices and link are kept independent for Redundancy.  Generally 2 WAN Links are used however I tried with Tertiary link too.

Configuration of all PE and Routers are in the snapshot below. Since the study is on HSRP we can Pre-build the network with config and keep it ready.

PE Configuration:- 

Router Configuration:-  Default hold timers 10 seconds both in HSRP v1 & v2, hence used hello 1sec & 3sec hold timer. Also we have to enable preempt, in VRRP its by default enabled however in HSRP we have to configure and for Link stability in Primary we used 5sec delay in Fallback.

Tracking Method:- It really depends on the design how we got to track the Main link for fail over. General practice is to track the route which is consistent because other tracking method can create high flapping causing problems to Router functioning.

              1. IP SLA based Object Tracking
We practice this scenario when there isn’t routing protocol on WAN interface, and high latency is observed in WAN then we could use multiple logic in IP SLA way of tracking. One of that is sending ICMP packets to certain IP on WAN side and in the event of packet loss there will be track down causing the fail over. There can various feature on ICMP that can be tracked like latency, jitter etc even the start time and end-times can be set.

R1(config)#track 1 ip sla 1 reachability
R1(config)#ip sla 1
R1(config)#icmp-echo 8.8.8.8
R1(config)#ip sla schedule 1 life forever start-time now

            2. Route lookup based Object Tracking
This is ideally way however this requires a routing protocol to be there in WAN link, the routes will go off only when the timers expires for it and restoration also been maintained with timer. hence Flapping of Tracks would not be that frequent maintaining the sanity of the Router process.

R1(config)#track 1 ip route 8.8.8.8 255.255.255.255 reachability

            3. Interface based Object Tracking.

This will track the line protocol status of the WAN interface connecting Main link. However has the drawback if the link is connected with many intermediate devices then end device link status remains always up even if the intermediate devices goes down.  If the interface flap occurs then that would cause track to flap in high frequency causing the fail-over too frequent for the network.

R1(config)#track 1 interface gigabitEthernet 1/0 line-protocol
R1(config-track)#exit

           4.Directly tracking WAN interface (Serial/ATM/POS. In HSRP you get this option.

R1(config)#standby 20 track Serial0/0  30  >> Decrements the current priority with value of 30

    

STATES OF HSRP:- 

All routers begin in the Initial state. This section discusses the intent of each state. For specific details on the actions taken in each state, please see the state transition table in section 5.7.

1. Initial :-  This is the starting state and indicates that HSRP is not running. This state is entered via a configuration change or when an interface first comes up.

2. Learn :-   The router has not determined the virtual IP address, and not yet seen an authenticated Hello message from the active router. In this state the router is still waiting to hear from the active router.

3. Listen:-   The router knows the virtual IP address, but is neither the active router nor the standby router. It listens for Hello messages from those routers.

4. Speak:-    The router sends periodic Hello messages and is actively participating in the election of the active and/or standby router. A router cannot enter Speak state unless it has the virtual IP address.

5. Standby:-  The router is a candidate to become the next active router and sends periodic Hello messages. Excluding transient conditions, there MUST be at most one router in the group in Standby state.

6. Active:-   The router is currently forwarding packets that are sent to the group’s virtual MAC address. The router sends periodic Hello messages. Excluding transient conditions, there MUST be at most one router in Active state in the group.

 

HSRP Message type and their opcode:

  • Hello :-  Opcode 0   (To indicate that a router is running to become/already in active or standby state.)
  • Coup :-  Opcode 1 (When a router wishes to become the active router having higher hsrp priority)
  • Resign:-  Opcode 2 (When a router no longer wishes to be the active router.)
  • Advertise:- Opcode 3 (When a router want to advertise it own state active/passive. It will be the initiating packet every time the port is configured or turns up)

 

 Normal Scenario:- We are going to remove all the HSRP config from Routers and configure one by one and how the behaviour will be is explained.

1. When you configure the first interface of HSRP that will go through set of states on each command as we enter in the interface.  As you see, just by entering standby IP and timers the state starts from INIT , sets the Group 1 MAC to 0000.0c07.ac01 to 50.0.0.1. LEARN state is when VIP is unknown, however we start with VIP command so no routers will have this state in debug. Then Try to LISTEN for 3 seconds, and timer expires so starts SPEAK with Hello packets out every sec having Priority, VIP, Group etc. Then it makes to state Standby until certain timer if no updates received from any in that group then it will become ACTIVE and start Hello packets every sec with state as ACTIVE.

Logs:- so far we haven’t configured the priority.

R1#config t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface GigabitEthernet1/0
R1(config-if)# ip address 50.0.0.2 255.255.255.0
R1(config-if)# negotiation auto
R1(config-if)# standby 1 ip 50.0.0.1
R1(config-if)# standby 1 timers 1 3
R1(config-if)#
*Mar 3 16:54:53.751: HSRP: Gi1/0 Interface UP
*Mar 3 16:54:53.755: HSRP: Gi1/0 Initialize swsb, Intf state Up
*Mar 3 16:54:53.759: HSRP: Gi1/0 Starting minimum intf delay (1 secs)
*Mar 3 16:54:53.759: HSRP: Gi1/0 Grp 1 Set virtual MAC 0000.0c07.ac01 type: v1 default
*Mar 3 16:54:53.763: HSRP: Gi1/0 MAC hash entry 0000.0c07.ac01, Added Gi1/0 Grp 1 to list
*Mar 3 16:54:53.783: HSRP: Gi1/0 Added 50.0.0.1 to hash table
*Mar 3 16:54:53.787: HSRP: Gi1/0 Grp 1 Has mac changed? cur 0000.0c07.ac01 new 0000.0c07.ac01
*Mar 3 16:54:53.787: HSRP: Gi1/0 Grp 1 Disabled -> Init
*Mar 3 16:54:53.791: HSRP: Gi1/0 Grp 1 Redundancy “hsrp-Gi1/0-1” state Disabled -> Init
*Mar 3 16:54:54.759: HSRP: Gi1/0 Intf min delay expired
*Mar 3 16:54:54.759: HSRP: Gi1/0 Grp 1 Init: a/HSRP enabled
*Mar 3 16:54:54.759: HSRP: Gi1/0 Grp 1 Init -> Listen
*Mar 3 16:54:54.763: HSRP: Gi1/0 Interface adv out, Passive, active 0 passive 1
*Mar 3 16:54:57.883: HSRP: Gi1/0 Grp 1 Listen: c/Active timer expired (unknown)
*Mar 3 16:54:57.883: HSRP: Gi1/0 Grp 1 Listen -> Speak
*Mar 3 16:54:57.887: HSRP: Gi1/0 Grp 1 Hello out 50.0.0.2 Speak pri 100 vIP 50.0.0.1
*Mar 3 16:54:58.891: HSRP: Gi1/0 Grp 1 Hello out 50.0.0.2 Speak pri 100 vIP 50.0.0.1
*Mar 3 16:54:59.907: HSRP: Gi1/0 Grp 1 Hello out 50.0.0.2 Speak pri 100 vIP 50.0.0.1
*Mar 3 16:55:00.455: HSRP: Gi1/0 Grp 1 Speak: d/Standby timer expired (unknown)
*Mar 3 16:55:00.455: HSRP: Gi1/0 Grp 1 Standby router is local
*Mar 3 16:55:00.459: HSRP: Gi1/0 Grp 1 Speak -> Standby
*Mar 3 16:55:00.459: HSRP: Gi1/0 Grp 1 Hello out 50.0.0.2 Standby pri 100 vIP 50.0.0.1
*Mar 3 16:55:01.271: HSRP: Gi1/0 Grp 1 Hello out 50.0.0.2 Standby pri 100 vIP 50.0.0.1
*Mar 3 16:55:01.495: HSRP: Gi1/0 Grp 1 Standby: c/Active timer expired (unknown)
*Mar 3 16:55:01.495: HSRP: Gi1/0 Grp 1 Active router is local
*Mar 3 16:55:01.495: HSRP: Gi1/0 Grp 1 Standby router is unknown, was local
*Mar 3 16:55:01.499: %HSRP-5-STATECHANGE: GigabitEthernet1/0 Grp 1 state Standby -> Active
*Mar 3 16:55:01.503: HSRP: Gi1/0 Interface adv out, Active, active 1 passive 0
*Mar 3 16:55:01.503: HSRP: Gi1/0 Grp 1 Redundancy “hsrp-Gi1/0-1” state Standby -> Active
*Mar 3 16:55:01.507: HSRP: Gi1/0 Grp 1 Hello out 50.0.0.2 Active pri 100 vIP 50.0.0.1
*Mar 3 16:55:01.511: HSRP: Gi1/0 Grp 1 Added 50.0.0.1 to ARP (0000.0c07.ac01)
*Mar 3 16:55:01.515: HSRP: Gi1/0 Grp 1 Activating MAC 0000.0c07.ac01
*Mar 3 16:55:01.519: HSRP: Gi1/0 Grp 1 Adding 0000.0c07.ac01 to MAC address filter
R1(config-if)#
*Mar 3 16:55:02.403: HSRP: Gi1/0 Grp 1 Hello out 50.0.0.2 Active pri 100 vIP 50.0.0.1
*Mar 3 16:55:03.323: HSRP: Gi1/0 Grp 1 Hello out 50.0.0.2 Active pri 100 vIP 50.0.0.1
R1(config-if)#
*Mar 3 16:55:07.887: HSRP: Gi1/0 Grp 1 Hello out 50.0.0.2 Active pri 100 vIP 50.0.0.1
*Mar 3 16:55:08.815: HSRP: Gi1/0 Grp 1 Hello out 50.0.0.2 Active pri 100 vIP 50.0.0.1

R1 starts from Init by sending Adv as Passive.

R1 sends hello SPEAK packets to see if any other router present.

R1 become standby for couple of seconds and become ACTIVE if no update received.

R1 become ACTIVE and sent an advertisement.

R1 sends hello with Active State. Actual HSRP MAC start now for R1 as OC:07:ac:01 sending to Multicast MAC.

R1 will send Gratuitous ARP with opcode 2 to inform L2 devices to update their MAC Table.

 

Now I entered following commands in R1, the hello packets started having priority 120 and track is enabled. so far there is no other packets received from any other routers in that HSRP group. Since we have not activated any other Routers in this HSRP Group.

Logs:-  Hello packets are sent with priority change and no other state change seen.

R1(config-if)# standby 1 priority 120
R1(config-if)# standby 1 preempt delay minimum 5
R1(config-if)# standby 1 track 1 decrement 30
R1(config-if)#end
*Mar 3 16:55:22.227: HSRP: Gi1/0 Grp 1 Priority 100 -> 120
*Mar 3 16:55:22.275: HSRP: Gi1/0 Grp 1 Hello out 50.0.0.2 Active pri 120 vIP 50.0.0.1
*Mar 3 16:55:22.299: HSRP: Gi1/0 Grp 1 Track 1 add, priority decrement 30
*Mar 3 16:55:22.299: HSRP: Gi1/0 Grp 1 Track 1 Start tracking
*Mar 3 16:55:22.299: HSRP: Gi1/0 Grp 1 Track 1 link id 1
*Mar 3 16:55:23.183: HSRP: Gi1/0 Grp 1 Hello out 50.0.0.2 Active pri 120 vIP 50.0.0.1
R1(config-if)#end
*Mar 3 16:55:24.087: HSRP: Gi1/0 Grp 1 Hello out 50.0.0.2 Active pri 120 vIP 50.0.0.1
*Mar 3 16:55:25.031: HSRP: Gi1/0 Grp 1 Hello out 50.0.0.2 Active pri 120 vIP 50.0.0.1

 

Now when we configure the R2 router, it will start with passive advertisement.  Then R2 sends out speak hello with all details and becomes standby after comparing priority values of R1 hello. R2 keep sending hello with its state Standby, Priority, Group etc. Once the command for priority is entered, the hello packet would have updated priority. Also while R3 comes up, it doesn’t send Speak Hello as there is already Active & Standby been elected and sending hello’s. R3 will just send a Passive packet when it turns up.

 

R2(config)#interface GigabitEthernet1/0
R2(config-if)# ip address 50.0.0.3 255.255.255.0
R2(config-if)# negotiation auto
R2(config-if)# standby 1 ip 50.0.0.1
R2(config-if)# standby 1 timers 1 3
*Mar 3 16:57:01.939: HSRP: Gi1/0 Interface UP
*Mar 3 16:57:01.943: HSRP: Gi1/0 Initialize swsb, Intf state Up
*Mar 3 16:57:01.943: HSRP: Gi1/0 Starting minimum intf delay (1 secs)
*Mar 3 16:57:01.943: HSRP: Gi1/0 Grp 1 Set virtual MAC 0000.0c07.ac01 type: v1 default
*Mar 3 16:57:01.943: HSRP: Gi1/0 MAC hash entry 0000.0c07.ac01, Added Gi1/0 Grp 1 to list
*Mar 3 16:57:01.951: HSRP: Gi1/0 Added 50.0.0.1 to hash table
*Mar 3 16:57:01.951: HSRP: Gi1/0 Grp 1 Has mac changed? cur 0000.0c07.ac01 new 0000.0c07.ac01
*Mar 3 16:57:01.951: HSRP: Gi1/0 Grp 1 Disabled -> Init
*Mar 3 16:57:02.415: HSRP: Gi1/0 Grp 1 Hello in 50.0.0.2 Active pri 120 vIP 50.0.0.1
*Mar 3 16:57:02.419: HSRP: Gi1/0 Grp 1 Active router is 50.0.0.2
*Mar 3 16:57:02.419: HSRP: Gi1/0 Nbr 50.0.0.2 created
*Mar 3 16:57:02.423: HSRP: Gi1/0 Nbr 50.0.0.2 active for group 1
*Mar 3 16:57:02.951: HSRP: Gi1/0 Intf min delay expired
*Mar 3 16:57:02.951: HSRP: Gi1/0 Grp 1 Init: a/HSRP enabled
*Mar 3 16:57:02.951: HSRP: Gi1/0 Grp 1 Init -> Listen
*Mar 3 16:57:02.951: HSRP: Gi1/0 Interface adv out, Passive, active 0 passive 1
*Mar 3 16:57:02.951: HSRP: Gi1/0 Grp 1 Redundancy “hsrp-Gi1/0-1” state Init -> Backup
*Mar 3 16:57:02.955: HSRP: Gi1/0 IP Redundancy “hsrp-Gi1/0-1” update, Init -> Backup

*Mar 3 16:57:03.375: HSRP: Gi1/0 Grp 1 Hello in 50.0.0.2 Active pri 120 vIP 50.0.0.1
*Mar 3 16:57:04.227: HSRP: Gi1/0 Grp 1 Hello in 50.0.0.2 Active pri 120 vIP 50.0.0.1
*Mar 3 16:57:05.087: HSRP: Gi1/0 Grp 1 Hello in 50.0.0.2 Active pri 120 vIP 50.0.0.1
*Mar 3 16:57:05.899: HSRP: Gi1/0 Grp 1 Hello in 50.0.0.2 Active pri 120 vIP 50.0.0.1
*Mar 3 16:57:06.403: HSRP: Gi1/0 Grp 1 Listen: d/Standby timer expired (unknown)
*Mar 3 16:57:06.403: HSRP: Gi1/0 Grp 1 Listen -> Speak
*Mar 3 16:57:06.403: HSRP: Gi1/0 Grp 1 Hello out 50.0.0.3 Speak pri 100 vIP 50.0.0.1
*Mar 3 16:57:06.791: HSRP: Gi1/0 Grp 1 Hello in 50.0.0.2 Active pri 120 vIP 50.0.0.1
*Mar 3 16:57:07.251: HSRP: Gi1/0 Grp 1 Hello out 50.0.0.3 Speak pri 100 vIP 50.0.0.1
*Mar 3 16:57:07.787: HSRP: Gi1/0 Grp 1 Hello in 50.0.0.2 Active pri 120 vIP 50.0.0.1
*Mar 3 16:57:08.131: HSRP: Gi1/0 Grp 1 Hello out 50.0.0.3 Speak pri 100 vIP 50.0.0.1
*Mar 3 16:57:08.619: HSRP: Gi1/0 Grp 1 Hello in 50.0.0.2 Active pri 120 vIP 50.0.0.1
*Mar 3 16:57:09.075: HSRP: Gi1/0 Grp 1 Hello out 50.0.0.3 Speak pri 100 vIP 50.0.0.1
*Mar 3 16:57:09.587: HSRP: Gi1/0 Grp 1 Hello in 50.0.0.2 Active pri 120 vIP 50.0.0.1
*Mar 3 16:57:09.971: HSRP: Gi1/0 Grp 1 Speak: d/Standby timer expired (unknown)
*Mar 3 16:57:09.971: HSRP: Gi1/0 Grp 1 Standby router is local
*Mar 3 16:57:09.971: HSRP: Gi1/0 Grp 1 Speak -> Standby
*Mar 3 16:57:09.971: %HSRP-5-STATECHANGE: GigabitEthernet1/0 Grp 1 state Speak -> Standby
*Mar 3 16:57:09.971: HSRP: Gi1/0 Grp 1 Hello out 50.0.0.3 Standby pri 100 vIP 50.0.0.1
*Mar 3 16:57:10.523: HSRP: Gi1/0 Grp 1 Hello in 50.0.0.2 Active pri 120 vIP 50.0.0.1
*Mar 3 16:57:10.867: HSRP: Gi1/0 Grp 1 Hello out 50.0.0.3 Standby pri 100 vIP 50.0.0.1
*Mar 3 16:57:11.531: HSRP: Gi1/0 Grp 1 Hello in 50.0.0.2 Active pri 120 vIP 50.0.0.1
*Mar 3 16:57:11.859: HSRP: Gi1/0 Grp 1 Hello out 50.0.0.3 Standby pri 100 vIP 50.0.0.1
*Mar 3 16:57:12.415: HSRP: Gi1/0 Grp 1 Hello in 50.0.0.2 Active pri 120 vIP 50.0.0.1
*Mar 3 16:57:12.707: HSRP: Gi1/0 Grp 1 Hello out 50.0.0.3 Standby pri 100 vIP 50.0.0.1
R2(config-if)# standby 1 priority 110
R2(config-if)# standby 1 preempt delay minimum 5
R2(config-if)# standby 1 track 1 decrement 30
R2(config-if)#end
*Mar 3 16:57:15.247: HSRP: Gi1/0 Grp 1 Hello in 50.0.0.2 Active pri 120 vIP 50.0.0.1
*Mar 3 16:57:15.427: HSRP: Gi1/0 Grp 1 Hello out 50.0.0.3 Standby pri 100 vIP 50.0.0.1
*Mar 3 16:57:16.263: HSRP: Gi1/0 Grp 1 Hello in 50.0.0.2 Active pri 120 vIP 50.0.0.1
*Mar 3 16:57:16.299: HSRP: Gi1/0 Grp 1 Priority 100 -> 110
*Mar 3 16:57:16.331: HSRP: Gi1/0 Grp 1 Track 1 add, priority decrement 30
*Mar 3 16:57:16.331: HSRP: Gi1/0 Grp 1 Track 1 Start tracking
*Mar 3 16:57:16.331: HSRP: Gi1/0 Grp 1 Track 1 link id 1
*Mar 3 16:57:16.427: HSRP: Gi1/0 Grp 1 Hello out 50.0.0.3 Standby pri 110 vIP 50.0.0.1
*Mar 3 16:57:17.099: HSRP: Gi1/0 Grp 1 Hello in 50.0.0.2 Active pri 120 vIP 50.0.0.1
*Mar 3 16:57:17.355: HSRP: Gi1/0 Grp 1 Hello out 50.0.0.3 Standby pri 110 vIP 50.0.0.1
*Mar 3 16:57:18.083: HSRP: Gi1/0 Grp 1 Hello in 50.0.0.2 Active pri 120 vIP 50.0.0.1
*Mar 3 16:57:18.331: HSRP: Gi1/0 Grp 1 Hello out 50.0.0.3 Standby pri 110 vIP 50.0.0.1
*Mar 3 16:57:19.059: HSRP: Gi1/0 Grp 1 Hello in 50.0.0.2 Active pri 120 vIP 50.0.0.1
*Mar 3 16:57:19.291: HSRP: Gi1/0 Grp 1 Hello out 50.0.0.3 Standby pri 110 vIP 50.0.0.1
*Mar 3 16:57:54.907: HSRP: Gi1/0 Grp 1 Hello in 50.0.0.2 Active pri 120 vIP 50.0.0.1
*Mar 3 16:57:55.267: HSRP: Gi1/0 Interface adv in, Passive, active 0, passive 1, from 50.0.0.4
*Mar 3 16:57:55.267: HSRP: Gi1/0 Nbr 50.0.0.4 Adv in, active 0 passive 1
*Mar 3 16:57:55.267: HSRP: Gi1/0 Nbr 50.0.0.4 created
*Mar 3 16:57:55.267: HSRP: Gi1/0 Nbr 50.0.0.4 is passive
*Mar 3 16:57:55.519: HSRP: Gi1/0 Grp 1 Hello out 50.0.0.3 Standby pri 110 vIP 50.0.0.1
*Mar 3 16:57:55.871: HSRP: Gi1/0 Interface adv out, Passive, active 0 passive 1
*Mar 3 16:57:55.883: HSRP: Gi1/0 Grp 1 Hello in 50.0.0.2 Active pri 120 vIP 50.0.0.1
*Mar 3 16:57:56.367: HSRP: Gi1/0 Grp 1 Hello out 50.0.0.3 Standby pri 110 vIP 50.0.0.1
*Mar 3 16:57:56.695: HSRP: Gi1/0 Grp 1 Hello in 50.0.0.2 Active pri 120 vIP 50.0.0.1
*Mar 3 16:57:57.215: HSRP: Gi1/0 Grp 1 Hello out 50.0.0.3 Standby pri 110 vIP 50.0.0.1

R2 start with Advertise packet as state Passive.

R2 send Hello with speak state to engage in election for Active/standby state with all other Routers in HSRP group.

R2 send Hello with Standby state after election completes 4 Speak packet. Then L2 will be flooded with constant hello packets of Active and Standby until a Event of Track down or New Router joins the HSRP Group.

 

Now when we configure the R3 router, port comes up and start with INIT state then to Listen, meanwhile there are already Hello’s received from R2 and R1 hence the priority is compared and stays in Listen state by sending passive advertisement once. It will stay in Listen state until Active/Standby are down and hello’s stop.

R3(config)#interface GigabitEthernet1/0
R3(config-if)# ip address 50.0.0.4 255.255.255.0
R3(config-if)# negotiation auto
R3(config-if)# standby 1 ip 50.0.0.1
R3(config-if)# standby 1 timers 1 3
R3(config-if)# standby 1 preempt delay minimum 5
*Mar 3 16:56:22.827: HSRP: Gi1/0 Initialize swsb, Intf state Down
*Mar 3 16:56:22.827: HSRP: Gi1/0 Grp 1 Set virtual MAC 0000.0c07.ac01 type: v1 default
*Mar 3 16:56:22.827: HSRP: Gi1/0 MAC hash entry 0000.0c07.ac01, Added Gi1/0 Grp 1 to list
*Mar 3 16:56:22.839: HSRP: Gi1/0 Added 50.0.0.1 to hash table
*Mar 3 16:56:22.839: HSRP: Gi1/0 Grp 1 Has mac changed? cur 0000.0c07.ac01 new 0000.0c07.ac01
*Mar 3 16:56:22.843: HSRP: Gi1/0 Grp 1 Disabled -> Init
*Mar 3 16:56:44.331: HSRP: Gi1/0 Interface UP
*Mar 3 16:56:44.331: HSRP: Gi1/0 Starting minimum intf delay (1 secs)
*Mar 3 16:56:44.655: HSRP: Gi1/0 Grp 1 Hello in 50.0.0.3 Standby pri 110 vIP 50.0.0.1
*Mar 3 16:56:44.659: HSRP: Gi1/0 Grp 1 Standby router is 50.0.0.3
*Mar 3 16:56:44.659: HSRP: Gi1/0 Nbr 50.0.0.3 created
*Mar 3 16:56:44.663: HSRP: Gi1/0 Nbr 50.0.0.3 standby for group 1
*Mar 3 16:56:44.979: HSRP: Gi1/0 Grp 1 Hello in 50.0.0.2 Active pri 120 vIP 50.0.0.1
*Mar 3 16:56:44.983: HSRP: Gi1/0 Grp 1 Active router is 50.0.0.2
*Mar 3 16:56:44.983: HSRP: Gi1/0 Nbr 50.0.0.2 created
*Mar 3 16:56:44.987: HSRP: Gi1/0 Nbr 50.0.0.2 active for group 1
*Mar 3 16:56:45.323: HSRP: Gi1/0 Intf min delay expired
*Mar 3 16:56:45.323: HSRP: Gi1/0 Grp 1 Init: a/HSRP enabled
*Mar 3 16:56:45.323: HSRP: Gi1/0 Grp 1 Init -> Listen
*Mar 3 16:56:45.327: HSRP: Gi1/0 Interface adv out, Passive, active 0 passive 1
*Mar 3 16:56:45.603: HSRP: Gi1/0 Grp 1 Hello in 50.0.0.3 Standby pri 110 vIP 50.0.0.1
*Mar 3 16:56:45.959: HSRP: Gi1/0 Grp 1 Hello in 50.0.0.2 Active pri 120 vIP 50.0.0.1
*Mar 3 16:56:46.435: HSRP: Gi1/0 Grp 1 Hello in 50.0.0.3 Standby pri 110 vIP 50.0.0.1
*Mar 3 16:56:46.779: HSRP: Gi1/0 Grp 1 Hello in 50.0.0.2 Active pri 120 vIP 50.0.0.1
*Mar 3 16:56:47.287: HSRP: Gi1/0 Grp 1 Hello in 50.0.0.3 Standby pri 110 vIP 50.0.0.1
*Mar 3 16:56:47.695: HSRP: Gi1/0 Grp 1 Hello in 50.0.0.2 Active pri 120 vIP 50.0.0.1
*Mar 3 16:56:48.123: HSRP: Gi1/0 Grp 1 Hello in 50.0.0.3 Standby pri 110 vIP 50.0.0.1

R3#sh stan b
P indicates configured to preempt.
Interface      Grp      Pri    P     State     Active         Standby      Virtual IP
Gi1/0              1         100   P     Listen   50.0.0.2   50.0.0.3        50.0.0.1

Every 15sec all the device in HSRP group will send a Passive state advertisement to just let the group knows about number of passive device existence except the Active router.

R3 just sent a passive advertisement and no other update as you see below:-

 

 

Failover 1:- In the event of Primary Track going down for various reasons of WAN failure, then fail-over will happen. Behavior of other Routers is explained.

 

Fallback:- When Primary link restores the Active link from Secondary will fallback to Primary.

 

Failover 2:- In the event of Secondary Track going down for various reasons of WAN failure, then fail-over will happen. Behavior of other Routers is explained.

 

Fallback:- When Secondary link restores the Standby state from Tertiary will fallback to Secondary Router.

Note :-   We don’t have to worry much about two more cases, where the secondary link goes down while primary is still up. As primary would stay active and will send traffic, the election will happen for standby state based on priority. Also in the event of tertiary link goes down while primary and sec is still up, will be null event as in HSRP priority is mostly to find Active and Standby.

 

Special USED CASE 1:-  PRI And SEC is Active and Active. When link between Switches go Down or if there is issue in Switch configuration due to which L2 packet of HSRP can’t flow between routers.  Even chances are there of Router LAN interface having ACL which blocks HSRP packets. In such case both Primary and Secondary stays Active.

 

 

1 Star2 Stars3 Stars4 Stars5 Stars (3 votes, average: 5.00 out of 5)
Loading…

Author: Ramesh